FLASH 7 PLUGIN REQUIRED!

In order to play «Save Your Skin!» you need the Flash-Plugin version 7 or above. You can get the plugin from the Macromedia-Website:

www.macromedia.com/go/getflash

Return to the game
     

© 2006 Editor Guenter BURG, M. D. - Department of Dermatology, University Hospital, Zürich - Rate "Save your skin!" - Questions & Feedback - Back to DOIT